mac10.8にvagrant+centos64+rails4インストール健忘録

ドットインストールruby on railsの動画がrails4に対応した事もあり、勉強をはじめました。
ドットインストールで3個目の動画に進む為の記録です。(rails sができるまで)
※turbolinksオフについてと、失敗ログを追加しました

ドットインストールはvagrantにrails4のインストールが済んでいて、バーチャルホストも設定されている状態でした。
気軽に初めてみたのですがrailsインストールするだけで3日間の超難産でした。

railsインストールの敷居を下げる事ができれば本望ですたい。
でも、一個一個調べたほうが勉強になると思うです。はい。
下記は、挑戰3日の集大成でもあるです。(つまり、1日、2日目の失敗を踏まえています)

■vagrantとvirtualboxのバージョンアップ

vagrant
http://www.vagrantup.com/

virtualbox
https://www.virtualbox.org/

どちらもダウンロードしてきて、上書きすればおk
vagrant 1.2.2→1.3.1
virtualbox 4.2.16→4.2.18
になりました。
バージョンアップはエラー回避の助けとなったか確定ではありませんが、バージョンアップ前に出ていたエラーは以後でなくなったように思います。(不確か)

ちなみにboxは
http://www.vagrantbox.es/
CentOS 6.4 x86_64 Minimal (VirtualBox Guest Additions 4.2.12, Chef 11.4.4, Puppet 3.1.1)を使ってます。
こっちは変わりなかったので更新せず。

vagrantの使い方はぐぐったり、当サイトの記録なども参考にしてください。

■vagrantにログインしてrootになる


#ディレクトリ作成
mkdir ~/study/rails_study/test
#移動
cd ~/study/rails_study/test

#用意してあるboxを使って設置(初期化)
vagrant init centos64
#鯖立ち上げ
vagrant up
#接続
vagrant ssh

#rootになる
su
#パスをいれる
vagrant

ドットインストールではもしかしたらvagrantユーザにroot権限を与えてるかもしれない。
また、rootになるのはsudoコマンドを使ってインストールすると/root/にインストールされるのを避ける為。
それにsudo地獄面倒くさいから。

■gemパッケージ入れる

rubyをc言語にコンパイルする為にgccが必要。
ruby 2.0をいれる為にopenssl-develが必要。
ソースファイルからファイルを作成するのにmakeが必要。
gitコマンドを使うのにgit必要。

以上が最低限必要かなとおもったのでyumコマンドでいれます。
オプション-yはanswer yes for all questionsするって事。(yum -hより


yum -y install gcc openssl-devel make git

■ruby2.0をインストールする


#移動
cd /usr/local
#gitでrbenv取得
git clone git://github.com/sstephenson/rbenv.git rbenv
#ディレクトリ作成
mkdir rbenv/shims rbenv/versions
#rbenvっていうグループを作成
groupadd rbenv
#rbenvディレクトリのグループをrbenvに変更
chgrp -R rbenv rbenv
#パーミッション変更
chmod -R g+rwxXs rbenv
#gitからruby-buildを取得
git clone git://github.com/sstephenson/ruby-build.git ruby-build
#移動
cd ruby-build
#ruby-buildが/usr/local/にインストールされる
#ちなみにinstall.shを編集すれば設置場所を変更可能
./install.sh

#rbenvの環境変数を設定
vi /etc/profile.d/rbenv.sh
#下記を記述
export RBENV_ROOT="/usr/local/rbenv"
export PATH="/usr/local/rbenv/bin:$PATH"
eval "$(rbenv init -)"

#gemとはRubyGemsのコマンド。
#RubyGemsで色々なライブラリが存在している
#bundleとは手動ではなく、設定ファイルを読んでgemパッケージを自動でインストールしてくれる
#Gemfileをbundlerが同じgemパッケージをインストールしてくれるです。
#rails installの時に必要なgemパッケージをインストールしてくれるです。
#iはinstallの略
gem i bundler

#鯖からでる
exit
exit

#鯖再起動
vagrant reload(vagrant halt、vagrant up)
vagrant ssh
#rootになる
su
#パスいれる
vagrant

#ruby バージョンを確認する(1.8.7とかでるはず
ruby -v
#ruby 一覧
rbenv install -l
#目的のバージョンをインストール。ながい
rbenv install 2.0.0-p247
#インストールしてあるrubyを確認する
rbenv versions
#切り替える
rbenv global 2.0.0-p247
#再度確認する
ruby -v

■railsインストールが速くなるおまじない

参考:href=”http://www.ideaxidea.com/archives/2013/08/resolv.html


vi /etc/resolv.conf
#以下を記述
options single-request-reopen

#gemコマンドにデフォルトでオプションをつける
vi ~/.gemrc
#ドキュメントとかインストールさせないオプションを付与
gem: --no-ri --no-rdoc
■rubygemsのバージョンアップをしておく

gem update --system
rbenv rehash
update_rubygems

■railsインストール


#インストール。しばし待つ。
gem i rails

ここで、sdoc、json1.8.0、sqlite3が必要だとか言われたので入れていきます。


gem i sdoc
gem i json
gem i sqlite3
rbenv rehash

上記をインストールしてもbundle installの所でエラーが起きる場合は、鯖を再起動してみてください。
何度かやっている内にインストールできました。
多分、↑が最後の難関ですかね。


#インストールが成功って出ると思う
#でない場合は根気よくぐぐる
gem i rails
#バージョンを確認
rails -v

多分、コマンドがないとか言われると思う。
gem listと打ってrails(4.0.0)があればその理由は下記の通りです。頑張って読みましょう。


rbenv rehash
https://github.com/sstephenson/rbenv#rbenv-rehash
Installs shims for all Ruby executables known to rbenv (i.e.,~/.rbenv/versions/*/bin/*). Run this command after you install a new version of Ruby, or install a gem that provides commands.

#rehashする
rbenv rehash
#確認する
rails -v

表示されましたね?
私はここで二日間つまってました。頭皮が50%ハゲました。

■Turbolinksは切ってもいいんじゃないかと思う

Turbolinksについて知りましょう。
詳しい事は、下記のサイトで紹介されています。
rails 4のturbolinksについて最低でも知っておきたい事

Rails 4のturbolinksについて最低でも知っておきたい事

会社の先輩に使わないほうがいいよと言われて、自分でも調べてみました。
自分もよっぽどでなければいらないなぁっていうのが結論です。
切っておいたほうが勉強しやすいし色々できると思うです。

rails4を勉強するのが主題。Turbolinks対応をしたい訳ではない
出身がwebコーダーの為、jqueryプラグインを自由に使えないのがつらい
対応されている問題を対処する為にgemをインストールするのは美しくない
仕事でも工数が増える事は避けたいので、Turbolinksは切りたい
ドットインストールでもTurbolinksうんぬんはでてこなそう
Turbolinks切ったほうがいいよって記事をあまり見なかったので、
rails経験がある人→勉強のためにいれてる
rails経験がない人→存在を知らない
だと想像。

詳しい人からすると、いやいやオフにするなよ!って怒られるのかもしれませんが、
勉強の順序としてもrails4のコードをとにかく書けハゲしてるほうが有意義だと思うです。

もし、興味があればやってみればいいです。
後から入れられるし、消す事もできます。
私のような面倒くさがりは最初からなかった事にすればいいと思います。(d゚ω゚d)オゥイェー

■railsサーバーを立ち上げる


#ここで作ったディレクトリ名がアプリ名と思っても間違いじゃないかな?
cd /home/vagrant
#Turbolinksがbundlerでインストールされないようにスキップしてプロジェクトだけ作ります
#スキップする事で最後のbundle installをしないって事ですね
rails new myapp --skip-bundle
cd myapp

vi Gemfile
#下記のようにコメントアウトする
#gem 'turbolinks'

#cssとjsでturbolinksをtrueにしている所が不要になるので削除
vi app/views/layouts/application.html.erb


#共通読み込みでturbolinks.jsが読まれないようにする
vi app/assets/javascript/application.js
#下記の一行を削除する
//= require turbolinks

#スキップしていたbundle installをする
bundle install
rails s
多分ここでjsのランタイムがーっていうエラーが出ると思います。

vi Gemfile
#therubyracerのコメントアウトを取る
bundle install
rails s

無事立ち上がりました。
http://localhost:3000にアクセスします。
welcomeページが確認できました。

■IPアドレスでつながるようにしよう


#railsサーバーを停める
command + C
exit
exit
vi Vagrantfile

#下記をご覧ください
  # Create a private network, which allows host-only access to the machine
  # using a specific IP.
  # config.vm.network :private_network, ip: "192.168.33.10"
#英語も読みましょう
#ではコメントアウトを外して保存します。
config.vm.network :private_network, ip: "192.168.33.10"

#鯖再起動〜
vagrant reload
vagrant ssh
su
vagrant
cd myapp
rails s

http://192.168.33.10にアクセスしてwelcomeページが見れました。

■バーチャルホストでつながるようにする


command + C
exit
exit
vi /etc/hosts
#下記を追加
192.168.33.10 test.rails.com

vagrant ssh
su
vagrant
cd myapp
rails s

http://test.rails.comにアクセスしてwelcomeページが見れました。

と、ruby on railsの動画を見るまでにこんな過程が省略されているかと思うです。
vagrantの動画を見てもrailsのインストールが書いてあるわけでもないので、
私のような初心者はrailsのインストールでかなーり苦戦するんじゃないかと思うです。
でも、お陰でスゴイ勉強になったです。動いてよかった。

■参考にさせて頂いたページ

CentOSでsystem wideなrbenv+ruby-build環境を構築する
http://nomnel.net/blog/centos-system-wide-rbenv-and-ruby-build/
Vagrant+VirtualBox(CentOS6)で「gem install rails」がすっごい遅い時の対処法
http://www.ideaxidea.com/archives/2013/08/resolv.html
rbenv rehash
https://github.com/sstephenson/rbenv#rbenv-rehash
download RubyGems
http://rubygems.org/pages/download
■1日目の奮闘ログ


harapekoAir:rails_study harapeko$ vagrant init centos64
A `Vagrantfile` has been placed in this directory. You are now
ready to `vagrant up` your first virtual environment! Please read
the comments in the Vagrantfile as well as documentation on
`vagrantup.com` for more information on using Vagrant.
harapekoAir:rails_study harapeko$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
vag[default] Importing base box 'centos64'...
Progress: 10%ssh
[default] Matching MAC address for NAT networking...
[default] Setting the name of the VM...
[default] Clearing any previously set forwarded ports...
[default] Creating shared folders metadata...
[default] Clearing any previously set network interfaces...
[default] Preparing network interfaces based on configuration...
[default] Forwarding ports...
[default] -- 22 => 2222 (adapter 1)
[default] Booting VM...
[default] Waiting for VM to boot. This can take a few minutes.
[default] VM booted and ready for use!
[default] Mounting shared folders...
[default] -- /vagrant
harapekoAir:rails_study harapeko$ vagrant ssh
Welcome to your Vagrant-built virtual machine.
[vagrant@localhost ~]$ ruby -v
ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
[vagrant@localhost ~]$ rails -v
-bash: rails: コマンドが見つかりません
[vagrant@localhost ~]$ rbenv
-bash: rbenv: コマンドが見つかりません
[vagrant@localhost ~]$ rbenv install -l
-bash: rbenv: コマンドが見つかりません
[vagrant@localhost ~]$ yum install openssl-devel
Loaded plugins: fastestmirror
You need to be root to perform this command.
[vagrant@localhost ~]$ sudo yum install openssl-devel
Loaded plugins: fastestmirror
Determining fastest mirrors
 * base: mirror.nus.edu.sg
 * extras: mirrors.btte.net
 * updates: centos.ustc.edu.cn
base                                                     | 3.7 kB     00:00
base/primary_db                                          | 4.4 MB     00:43
extras                                                   | 3.4 kB     00:00
extras/primary_db                                        |  18 kB     00:00
updates                                                  | 3.4 kB     00:00
updates/primary_db                                       | 4.4 MB     00:33
Setting up Install Process
Package openssl-devel-1.0.0-27.el6_4.2.x86_64 already installed and latest version
Nothing to do
[vagrant@localhost ~]$ su -
パスワード:
su: パスワードが違います
[vagrant@localhost ~]$ su -
パスワード:
su: パスワードが違います
[vagrant@localhost ~]$ su -
パスワード:
su: パスワードが違います
[vagrant@localhost ~]$ su
パスワード:
[root@localhost vagrant]# ls
[root@localhost vagrant]# pwd
/home/vagrant
[root@localhost vagrant]# su -
[root@localhost ~]# ls
anaconda-ks.cfg  install.log  install.log.syslog
[root@localhost ~]# pwd
/root
[root@localhost ~]# cd /usr/local/src/rbenv/plugins/ruby-build
-bash: cd: /usr/local/src/rbenv/plugins/ruby-build: No such file or directory
[root@localhost ~]# cd /usr/local/src/
[root@localhost src]# ls
[root@localhost src]# yum install gcc make git
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * extras: mirrors.btte.net
 * updates: centos.ustc.edu.cn
Setting up Install Process
Package gcc-4.4.7-3.el6.x86_64 already installed and latest version
Package 1:make-3.81-20.el6.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package git.x86_64 0:1.7.1-3.el6_4.1 will be installed
--> Processing Dependency: perl-Git = 1.7.1-3.el6_4.1 for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: rsync for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(Git) for package: git-1.7.1-3.el6_4.1.x86_64
--> Processing Dependency: perl(Error) for package: git-1.7.1-3.el6_4.1.x86_64
--> Running transaction check
---> Package perl-Error.noarch 1:0.17015-4.el6 will be installed
---> Package perl-Git.noarch 0:1.7.1-3.el6_4.1 will be installed
---> Package rsync.x86_64 0:3.0.6-9.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================
 Package                  Arch                 Version                       Repository             Size
=========================================================================================================
Installing:
 git                      x86_64               1.7.1-3.el6_4.1               updates               4.6 M
Installing for dependencies:
 perl-Error               noarch               1:0.17015-4.el6               base                   29 k
 perl-Git                 noarch               1.7.1-3.el6_4.1               updates                28 k
 rsync                    x86_64               3.0.6-9.el6                   base                  334 k

Transaction Summary
=========================================================================================================
Install       4 Package(s)

Total download size: 5.0 M
Installed size: 15 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): git-1.7.1-3.el6_4.1.x86_64.rpm                                             | 4.6 MB     00:31
(2/4): perl-Error-0.17015-4.el6.noarch.rpm                                        |  29 kB     00:00
(3/4): perl-Git-1.7.1-3.el6_4.1.noarch.rpm                                        |  28 kB     00:00
(4/4): rsync-3.0.6-9.el6.x86_64.rpm                                               | 334 kB     00:01
---------------------------------------------------------------------------------------------------------
Total                                                                     99 kB/s | 5.0 MB     00:51
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : 1:perl-Error-0.17015-4.el6.noarch                                                     1/4
  Installing : rsync-3.0.6-9.el6.x86_64                                                              2/4
  Installing : perl-Git-1.7.1-3.el6_4.1.noarch                                                       3/4
  Installing : git-1.7.1-3.el6_4.1.x86_64                                                            4/4
  Verifying  : git-1.7.1-3.el6_4.1.x86_64                                                            1/4
  Verifying  : rsync-3.0.6-9.el6.x86_64                                                              2/4
  Verifying  : perl-Git-1.7.1-3.el6_4.1.noarch                                                       3/4
  Verifying  : 1:perl-Error-0.17015-4.el6.noarch                                                     4/4

Installed:
  git.x86_64 0:1.7.1-3.el6_4.1

Dependency Installed:
  perl-Error.noarch 1:0.17015-4.el6    perl-Git.noarch 0:1.7.1-3.el6_4.1    rsync.x86_64 0:3.0.6-9.el6

Complete!
[root@localhost src]# git clone git://github.com/sstephenson/rbenv.git
Initialized empty Git repository in /usr/local/src/rbenv/.git/
remote: Counting objects: 1651, done.
remote: Compressing objects: 100% (672/672), done.
remote: Total 1651 (delta 1063), reused 1478 (delta 947)
Receiving objects: 100% (1651/1651), 239.64 KiB | 108 KiB/s, done.
Resolving deltas: 100% (1063/1063), done.
[root@localhost src]# vim ~/.bashrc
-bash: vim: command not found
[root@localhost src]# vim ~/.bashrc
-bash: vim: command not found
[root@localhost src]# vi ~/.bashrc
[root@localhost src]# source ~/.bashrc
[root@localhost src]# pwd
/usr/local/src
[root@localhost src]# cd rbenv/
[root@localhost rbenv]# ls
bin  completions  libexec  LICENSE  README.md  shims  test  versions
[root@localhost rbenv]# mkdir plugins
[root@localhost rbenv]# cd plugins/
[root@localhost plugins]# pwd
/usr/local/src/rbenv/plugins
[root@localhost plugins]# git clone git://github.com/sstephenson/ruby-build.git[
Initialized empty Git repository in /usr/local/src/rbenv/plugins/ruby-build.git[/.git/
fatal: remote error:
  sstephenson/ruby-build.git[ is not a valid repository name
  Email support@github.com for help
[root@localhost plugins]# git clone git://github.com/sstephenson/ruby-build.git
Initialized empty Git repository in /usr/local/src/rbenv/plugins/ruby-build/.git/
remote: Counting objects: 2153, done.
remote: Compressing objects: 100% (1255/1255), done.
remote: Total 2153 (delta 954), reused 1880 (delta 711)
Receiving objects: 100% (2153/2153), 287.75 KiB | 75 KiB/s, done.
Resolving deltas: 100% (954/954), done.
[root@localhost plugins]# ls
ruby-build
[root@localhost plugins]# cd ruby-build
[root@localhost ruby-build]# ls
bin  CHANGELOG.md  install.sh  LICENSE  README.md  share  test
[root@localhost ruby-build]# vim install.sh
-bash: vim: command not found
[root@localhost ruby-build]# vi install.sh
[root@localhost ruby-build]# vi install.sh
[root@localhost ruby-build]# ./install.sh
Installed ruby-build at /usr/local/src/rbenv
[root@localhost ruby-build]# rbenv install -l
Available versions:
  1.8.6-p383
  1.8.6-p420
  1.8.7-p249
  1.8.7-p302
  1.8.7-p334
  1.8.7-p352
  1.8.7-p357
  1.8.7-p358
  1.8.7-p370
  1.8.7-p371
  1.8.7-p374
  1.9.1-p378
  1.9.1-p430
  1.9.2-p0
  1.9.2-p180
  1.9.2-p290
  1.9.2-p318
  1.9.2-p320
  1.9.3-dev
  1.9.3-p0
  1.9.3-p125
  1.9.3-p194
  1.9.3-p286
  1.9.3-p327
  1.9.3-p362
  1.9.3-p374
  1.9.3-p385
  1.9.3-p392
  1.9.3-p429
  1.9.3-p448
  1.9.3-preview1
  1.9.3-rc1
  2.0.0-dev
  2.0.0-p0
  2.0.0-p195
  2.0.0-p247
  2.0.0-preview1
  2.0.0-preview2
  2.0.0-rc1
  2.0.0-rc2
  2.1.0-dev
  jruby-1.5.6
  jruby-1.6.3
  jruby-1.6.4
  jruby-1.6.5
  jruby-1.6.5.1
  jruby-1.6.6
  jruby-1.6.7
  jruby-1.6.7.2
  jruby-1.6.8
  jruby-1.7.0
  jruby-1.7.0-preview1
  jruby-1.7.0-preview2
  jruby-1.7.0-rc1
  jruby-1.7.0-rc2
  jruby-1.7.1
  jruby-1.7.2
  jruby-1.7.3
  jruby-1.7.4
  maglev-1.0.0
  maglev-1.1.0-dev
  maglev-2.0.0-dev
  mruby-dev
  rbx-1.2.4
  rbx-2.0.0-dev
  rbx-2.0.0-rc1
  ree-1.8.6-2009.06
  ree-1.8.7-2009.09
  ree-1.8.7-2009.10
  ree-1.8.7-2010.01
  ree-1.8.7-2010.02
  ree-1.8.7-2011.03
  ree-1.8.7-2011.12
  ree-1.8.7-2012.01
  ree-1.8.7-2012.02
  topaz-dev
[root@localhost ruby-build]# ruby install 2.0.0-p247
ruby: No such file or directory -- install (LoadError)
[root@localhost ruby-build]# rbenv install 2.0.0-p247
Downloading ruby-2.0.0-p247.tar.gz...
-> http://cache.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p247.tar.gz
Installing ruby-2.0.0-p247...
Installed ruby-2.0.0-p247 to /usr/local/src/rbenv/versions/2.0.0-p247

[root@localhost ruby-build]# rbenv versions
* system (set by /usr/local/src/rbenv/version)
  2.0.0-p247
[root@localhost ruby-build]# rbenv global
2.0.0-p247  system
[root@localhost ruby-build]# rbenv global
2.0.0-p247  system
[root@localhost ruby-build]# rbenv global 2.0.0-p247
[root@localhost ruby-build]# rbenv rehash
[root@localhost ruby-build]# rbenv version
2.0.0-p247 (set by /usr/local/src/rbenv/version)
[root@localhost ruby-build]# rbenv versions
  system
* 2.0.0-p247 (set by /usr/local/src/rbenv/version)
[root@localhost ruby-build]# which ruby
/usr/local/src/rbenv/shims/ruby
[root@localhost ruby-build]# ruby -v
ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux]
[root@localhost ruby-build]# vagrant halt
-bash: vagrant: command not found
[root@localhost ruby-build]# vagrant halt
-bash: vagrant: command not found
[root@localhost ruby-build]# exit
logout
[root@localhost vagrant]# vagrant halt
bash: vagrant: コマンドが見つかりません
[root@localhost vagrant]# vagrant halt
bash: vagrant: コマンドが見つかりません
[root@localhost vagrant]# exit
exit
[vagrant@localhost ~]$ logout
Connection to 127.0.0.1 closed.
harapekoAir:rails_study harapeko$ vagrant halt
[default] Attempting graceful shutdown of VM...
harapekoAir:rails_study harapeko$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
[default] Setting the name of the VM...
[default] Clearing any previously set forwarded ports...
[default] Creating shared folders metadata...
[default] Clearing any previously set network interfaces...
[default] Preparing network interfaces based on configuration...
[default] Forwarding ports...
[default] -- 22 => 2222 (adapter 1)
[default] Booting VM...
[default] Waiting for VM to boot. This can take a few minutes.
[default] VM booted and ready for use!
[default] Mounting shared folders...
[default] -- /vagrant
harapekoAir:rails_study harapeko$ vagrant ssh
Last login: Mon Sep  9 15:42:26 2013 from 10.0.2.2
Welcome to your Vagrant-built virtual machine.
[vagrant@localhost ~]$ su -
パスワード:
[root@localhost ~]# rais -v
-bash: rais: command not found
[root@localhost ~]# yum -y install rubygems
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * extras: mirrors.btte.net
 * updates: centos.ustc.edu.cn
base                                                                              | 3.7 kB     00:00
extras                                                                            | 3.4 kB     00:00
updates                                                                           | 3.4 kB     00:00
updates/primary_db                                                                | 4.4 MB     00:34
Setting up Install Process
Package rubygems-1.3.7-1.el6.noarch already installed and latest version
Nothing to do
[root@localhost ~]# yum -y install gcc gcc-c++ openssl-devel zlib-devel make patch sqlite-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * extras: mirrors.btte.net
 * updates: centos.ustc.edu.cn
Setting up Install Process
Package gcc-4.4.7-3.el6.x86_64 already installed and latest version
Package gcc-c++-4.4.7-3.el6.x86_64 already installed and latest version
Package openssl-devel-1.0.0-27.el6_4.2.x86_64 already installed and latest version
Package zlib-devel-1.2.3-29.el6.x86_64 already installed and latest version
Package 1:make-3.81-20.el6.x86_64 already installed and latest version
Package sqlite-devel-3.6.20-1.el6.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package patch.x86_64 0:2.6-6.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================
 Package                Arch                    Version                      Repository             Size
=========================================================================================================
Installing:
 patch                  x86_64                  2.6-6.el6                    base                   90 k

Transaction Summary
=========================================================================================================
Install       1 Package(s)

Total download size: 90 k
Installed size: 172 k
Downloading Packages:
patch-2.6-6.el6.x86_64.rpm                                                        |  90 kB     00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : patch-2.6-6.el6.x86_64                                                                1/1
  Verifying  : patch-2.6-6.el6.x86_64                                                                1/1

Installed:
  patch.x86_64 0:2.6-6.el6

Complete!
[root@localhost ~]# Connection to 127.0.0.1 closed by remote host.
Connection to 127.0.0.1 closed.
harapekoAir:rails_study harapeko$ ls
Vagrantfile
harapekoAir:rails_study harapeko$ vagrant ssh
VM must be running to open SSH connection. Run `vagrant up`
to start the virtual machine.
harapekoAir:rails_study harapeko$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
[default] Resuming suspended VM...
[default] Booting VM...
[default] Waiting for VM to boot. This can take a few minutes.
[default] VM booted and ready for use!
harapekoAir:rails_study harapeko$ vagrant ssh
Last login: Mon Sep  9 23:57:05 2013 from 10.0.2.2
Welcome to your Vagrant-built virtual machine.
[vagrant@localhost ~]$ yum -y install gcc gcc-c++ openssl-devel zlib-devel make patch sqlite-devel
Loaded plugins: fastestmirror
You need to be root to perform this command.
[vagrant@localhost ~]$ su -
パスワード:
[root@localhost ~]# yum -y install gcc gcc-c++ openssl-devel zlib-devel make patch sqlite-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * extras: mirrors.btte.net
 * updates: centos.ustc.edu.cn
Setting up Install Process
Package gcc-4.4.7-3.el6.x86_64 already installed and latest version
Package gcc-c++-4.4.7-3.el6.x86_64 already installed and latest version
Package openssl-devel-1.0.0-27.el6_4.2.x86_64 already installed and latest version
Package zlib-devel-1.2.3-29.el6.x86_64 already installed and latest version
Package 1:make-3.81-20.el6.x86_64 already installed and latest version
Package patch-2.6-6.el6.x86_64 already installed and latest version
Package sqlite-devel-3.6.20-1.el6.x86_64 already installed and latest version
Nothing to do
[root@localhost ~]# yum -y install gcc gcc-c++ openssl-devel zlib-devel make patch sqlite-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * extras: mirrors.btte.net
 * updates: centos.ustc.edu.cn
Setting up Install Process
Package gcc-4.4.7-3.el6.x86_64 already installed and latest version
Package gcc-c++-4.4.7-3.el6.x86_64 already installed and latest version
Package openssl-devel-1.0.0-27.el6_4.2.x86_64 already installed and latest version
Package zlib-devel-1.2.3-29.el6.x86_64 already installed and latest version
Package 1:make-3.81-20.el6.x86_64 already installed and latest version
Package patch-2.6-6.el6.x86_64 already installed and latest version
Package sqlite-devel-3.6.20-1.el6.x86_64 already installed and latest version
Nothing to do
[root@localhost ~]# cd /usr/local/src/
[root@localhost src]# wget http://pyyaml.org/download/libyaml/yaml-0.1.4.tar.gz
--2013-09-10 05:09:37--  http://pyyaml.org/download/libyaml/yaml-0.1.4.tar.gz
Resolving pyyaml.org... failed: Name or service not known.
wget: unable to resolve host address “pyyaml.org”
[root@localhost src]# wget http://pyyaml.org/download/libyaml/yaml-0.1.4.tar.gz
--2013-09-10 05:12:36--  http://pyyaml.org/download/libyaml/yaml-0.1.4.tar.gz
Resolving pyyaml.org... failed: Name or service not known.
wget: unable to resolve host address “pyyaml.org”
[root@localhost src]# ls
rbenv
[root@localhost src]# rubygems -v
-bash: rubygems: command not found
[root@localhost src]# rubygems
-bash: rubygems: command not found
[root@localhost src]# make
make: *** No targets specified and no makefile found.  Stop.
[root@localhost src]# cd rbenv/
[root@localhost rbenv]# ls
bin  completions  libexec  LICENSE  plugins  README.md  share  shims  test  version  versions
[root@localhost rbenv]# cd version
-bash: cd: version: Not a directory
[root@localhost rbenv]# ls
bin  completions  libexec  LICENSE  plugins  README.md  share  shims  test  version  versions
[root@localhost rbenv]# cd version
-bash: cd: version: Not a directory
[root@localhost rbenv]# cd versions
[root@localhost versions]# ls
2.0.0-p247
[root@localhost versions]# cd 2.0.0-p247/
[root@localhost 2.0.0-p247]# ls
bin  include  lib  share
[root@localhost 2.0.0-p247]# ./configure
-bash: ./configure: No such file or directory
[root@localhost 2.0.0-p247]# make
make: *** No targets specified and no makefile found.  Stop.
[root@localhost 2.0.0-p247]# make install
make: *** No rule to make target `install'.  Stop.
[root@localhost 2.0.0-p247]# ruby 0v
ruby: No such file or directory -- 0v (LoadError)
[root@localhost 2.0.0-p247]# ruby -v
ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux]
[root@localhost 2.0.0-p247]# cd ../../
[root@localhost rbenv]# ls
bin  completions  libexec  LICENSE  plugins  README.md  share  shims  test  version  versions
[root@localhost rbenv]# pwd
/usr/local/src/rbenv
[root@localhost rbenv]# cd ../
[root@localhost src]# gem install rails
ERROR:  Could not find a valid gem 'rails' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - no such name (https://rubygems.org/latest_specs.4.8.gz)
[root@localhost src]# gem install rails
ERROR:  Could not find a valid gem 'rails' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - no such name (https://rubygems.org/latest_specs.4.8.gz)
^C^CERROR:  Interrupted
/usr/local/src/rbenv/versions/2.0.0-p247/bin/gem: Interrupt

[root@localhost src]# gem update rails
Updating installed gems
Nothing to update
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# gem install rails
ERROR:  Could not find a valid gem 'rails' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - no such name (https://rubygems.org/latest_specs.4.8.gz)
[root@localhost src]# yum -y install rubygems
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * extras: mirrors.btte.net
 * updates: centos.ustc.edu.cn
Setting up Install Process
Package rubygems-1.3.7-1.el6.noarch already installed and latest version
Nothing to do
[root@localhost src]# gem install rails
ERROR:  Could not find a valid gem 'rails' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - no such name (https://rubygems.org/latest_specs.4.8.gz)
[root@localhost src]# wget ftp://ftp.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p195.tar.gz
--2013-09-10 05:26:18--  ftp://ftp.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p195.tar.gz
           => “ruby-2.0.0-p195.tar.gz”
Resolving ftp.ruby-lang.org... failed: Name or service not known.
wget: unable to resolve host address “ftp.ruby-lang.org”
[root@localhost src]# tar xzvf rubygems-2.0.3.tgz
tar (child): rubygems-2.0.3.tgz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
[root@localhost src]# tar xzvf rubygems-2.0.3.tgz
tar (child): rubygems-2.0.3.tgz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
[root@localhost src]# ls
rbenv
[root@localhost src]# gem -v
2.0.3
[root@localhost src]# gem install rails
ERROR:  Could not find a valid gem 'rails' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - no such name (https://rubygems.org/latest_specs.4.8.gz)
[root@localhost src]# sudo gem install rails

ERROR:  http://rubygems.org/ does not appear to be a repository
ERROR:  Could not find a valid gem 'rails' (>= 0) in any repository
[root@localhost src]#
[root@localhost src]#
[root@localhost src]#
[root@localhost src]# sudo gem update
Updating installed gems
ERROR:  http://rubygems.org/ does not appear to be a repository
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    SocketError: getaddrinfo: Name or service not known (http://rubygems.org/yaml)
[root@localhost src]# sudo gem update --system
Updating RubyGems
ERROR:  http://rubygems.org/ does not appear to be a repository
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    SocketError: getaddrinfo: Name or service not known (http://rubygems.org/yaml)
[root@localhost src]# wget /Users/harapeko/Downloads/yaml-0.1.4.tar.gz
/Users/harapeko/Downloads/yaml-0.1.4.tar.gz: Scheme missing.
[root@localhost src]# mv /Users/harapeko/Downloads/yaml-0.1.4.tar.gz
mv: missing destination file operand after `/Users/harapeko/Downloads/yaml-0.1.4.tar.gz'
Try `mv --help' for more information.
[root@localhost src]# cp /Users/harapeko/Downloads/yaml-0.1.4.tar.gz .
cp: cannot stat `/Users/harapeko/Downloads/yaml-0.1.4.tar.gz': No such file or directory
[root@localhost src]# cp /Users/harapeko/Downloads/yaml-0.1.4.tar.gz ./
cp: cannot stat `/Users/harapeko/Downloads/yaml-0.1.4.tar.gz': No such file or directory
[root@localhost src]# wget http://pyyaml.org/download/libyaml/yaml-0.1.4.tar.gz
--2013-09-10 05:37:23--  http://pyyaml.org/download/libyaml/yaml-0.1.4.tar.gz
Resolving pyyaml.org... failed: Name or service not known.
wget: unable to resolve host address “pyyaml.org”
[root@localhost src]# gem install rack
ERROR:  Could not find a valid gem 'rack' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - no such name (https://rubygems.org/latest_specs.4.8.gz)
^[[A^[[A^[[B[root@locagem install rack


ERROR:  Could not find a valid gem 'rack' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - no such name (https://rubygems.org/latest_specs.4.8.gz)
[root@localhost src]#
[root@localhost src]#
[root@localhost src]# gem list bundler

*** LOCAL GEMS ***


[root@localhost src]# gem install bundler
ERROR:  Could not find a valid gem 'bundler' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - no such name (https://rubygems.org/latest_specs.4.8.gz)
[root@localhost src]# gem list bundler

*** LOCAL GEMS ***


[root@localhost src]# gem update bundler
Updating installed gems
Nothing to update
[root@localhost src]# sudo gem install bundler
ERROR:  http://rubygems.org/ does not appear to be a repository
ERROR:  Could not find a valid gem 'bundler' (>= 0) in any repository
[root@localhost src]# sudo gem install bundler
ERROR:  http://rubygems.org/ does not appear to be a repository
ERROR:  Could not find a valid gem 'bundler' (>= 0) in any repository
[root@localhost src]# gem install rails
ERROR:  Could not find a valid gem 'rails' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - no such name (https://rubygems.org/latest_specs.4.8.gz)
^C^C^C^C^C^C^C^C^C^C^C^C^C^C^CERROR:  Interrupted
/usr/local/src/rbenv/versions/2.0.0-p247/bin/gem: Interrupt

[root@localhost src]# logout
[vagrant@localhost ~]$ exit
logout
Connection to 127.0.0.1 closed.
harapekoAir:rails_study harapeko$ vagrant halt
[default] Attempting graceful shutdown of VM...
harapekoAir:rails_study harapeko$ vagrant up
vagrantBringing machine 'default' up with 'virtualbox' provider...
 ssh
[default] Setting the name of the VM...
[default] Clearing any previously set forwarded ports...
[default] Creating shared folders metadata...
[default] Clearing any previously set network interfaces...
[default] Preparing network interfaces based on configuration...
[default] Forwarding ports...
[default] -- 22 => 2222 (adapter 1)
[default] Booting VM...
[default] Waiting for VM to boot. This can take a few minutes.
[default] VM booted and ready for use!
[default] Mounting shared folders...
[default] -- /vagrant
harapekoAir:rails_study harapeko$ vagrant ssh
Last login: Tue Sep 10 03:22:46 2013 from 10.0.2.2
Welcome to your Vagrant-built virtual machine.
[vagrant@localhost ~]$ cd /var/
[vagrant@localhost var]$ ls
cache  db  empty  games  lib  local  lock  log  mail  nis  opt  preserve  run  spool  tmp  yp
[vagrant@localhost var]$ cd local/
[vagrant@localhost local]$ ls
[vagrant@localhost local]$ cd ../../
[vagrant@localhost /]$ ls
bin   dev  home  lib64       media  opt   root  selinux  sys  usr      var
boot  etc  lib   lost+found  mnt    proc  sbin  srv      tmp  vagrant
[vagrant@localhost /]$ su -
パスワード:
[root@localhost ~]# cd /var/
[root@localhost var]# ls
cache  db  empty  games  lib  local  lock  log  mail  nis  opt  preserve  run  spool  tmp  yp
[root@localhost var]# cd local/
[root@localhost local]# ls
[root@localhost local]# cd ../../
[root@localhost /]# logout
[vagrant@localhost /]$ cd /usr/local/src/
[vagrant@localhost src]$ ls
rbenv
[vagrant@localhost src]$ sudo gem install rails
Building native extensions.  This could take a while...
ERROR:  Error installing rails:
     ERROR: Failed to build gem native extension.

/usr/bin/ruby extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/ruby.h


Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/atomic-1.1.13 for inspection.
Results logged to /usr/lib/ruby/gems/1.8/gems/atomic-1.1.13/ext/gem_make.out
[vagrant@localhost src]$ gem update --system
Updating RubyGems
Updating rubygems-update
ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions into the /usr/lib/ruby/gems/1.8 directory.
[vagrant@localhost src]$ sudo gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-2.1.0
Updating RubyGems to 2.1.0
Installing RubyGems 2.1.0
RubyGems 2.1.0 installed
Installing ri documentation for rubygems-2.1.0
/usr/lib/ruby/1.8/rdoc/rdoc.rb:280: warning: conflicting chdir during another chdir block
/usr/lib/ruby/1.8/rdoc/rdoc.rb:287: warning: conflicting chdir during another chdir block



------------------------------------------------------------------------------

RubyGems installed the following executables:
     /usr/bin/gem

Ruby Interactive (ri) documentation was installed. ri is kind of like man
pages for ruby libraries. You may access it like this:
  ri Classname
  ri Classname.class_method
  ri Classname#instance_method
If you do not wish to install this documentation in the future, use the
--no-document flag, or set it as the default in your ~/.gemrc file. See
'gem help env' for details.

[vagrant@localhost src]$ gem -v
2.1.0
[vagrant@localhost src]$ gem install rubygems-update
ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /usr/lib64/ruby/gems/1.8 directory.
[vagrant@localhost src]$ sudo gem install rubygems-update
Fetching: rubygems-update-2.1.0.gem (100%)
Successfully installed rubygems-update-2.1.0
Installing ri documentation for rubygems-update-2.1.0
/usr/lib/ruby/1.8/rdoc/rdoc.rb:280: warning: conflicting chdir during another chdir block
/usr/lib/ruby/1.8/rdoc/rdoc.rb:287: warning: conflicting chdir during another chdir block
Done installing documentation for rubygems-update after 0 seconds
1 gem installed
[vagrant@localhost src]$ sudo update_rubygems
RubyGems 2.1.0 installed
Installing ri documentation for rubygems-2.1.0
/usr/lib/ruby/1.8/rdoc/rdoc.rb:280: warning: conflicting chdir during another chdir block
/usr/lib/ruby/1.8/rdoc/rdoc.rb:287: warning: conflicting chdir during another chdir block



------------------------------------------------------------------------------

RubyGems installed the following executables:
     /usr/bin/gem

Ruby Interactive (ri) documentation was installed. ri is kind of like man
pages for ruby libraries. You may access it like this:
  ri Classname
  ri Classname.class_method
  ri Classname#instance_method
If you do not wish to install this documentation in the future, use the
--no-document flag, or set it as the default in your ~/.gemrc file. See
'gem help env' for details.

[vagrant@localhost src]$ sudo gems install rails
sudo: gems: コマンドが見つかりません
[vagrant@localhost src]$ sudo gem install rails
^C^C

ERROR:  Interrupted
[vagrant@localhost src]$
[vagrant@localhost src]$
[vagrant@localhost src]$ su -
パスワード:
[root@localhost ~]# pwd
/root
[root@localhost ~]# cd /usr/local/src/
[root@localhost src]# gem install rails




^C^CERROR:  Interrupted
/usr/local/src/rbenv/versions/2.0.0-p247/bin/gem: Interrupt

[root@localhost src]# pwd
/usr/local/src
[root@localhost src]# gen install bundler
-bash: gen: command not found
[root@localhost src]# gem install bundler
Fetching: bundler-1.3.5.gem (100%)
Successfully installed bundler-1.3.5
Parsing documentation for bundler-1.3.5
Installing ri documentation for bundler-1.3.5
1 gem installed
[root@localhost src]# gem list bundler

*** LOCAL GEMS ***

bundler (1.3.5)
[root@localhost src]# gem -v
2.0.3
[root@localhost src]# gem update --system
Updating rubygems-update
Fetching: rubygems-update-2.1.0.gem (100%)
Successfully installed rubygems-update-2.1.0
Parsing documentation for rubygems-update-2.1.0
Installing ri documentation for rubygems-update-2.1.0
Installing darkfish documentation for rubygems-update-2.1.0
Installing RubyGems 2.1.0
RubyGems 2.1.0 installed
Parsing documentation for rubygems-2.1.0
Installing ri documentation for rubygems-2.1.0



------------------------------------------------------------------------------

RubyGems installed the following executables:
     /usr/local/src/rbenv/versions/2.0.0-p247/bin/gem

Ruby Interactive (ri) documentation was installed. ri is kind of like man
pages for ruby libraries. You may access it like this:
  ri Classname
  ri Classname.class_method
  ri Classname#instance_method
If you do not wish to install this documentation in the future, use the
--no-document flag, or set it as the default in your ~/.gemrc file. See
'gem help env' for details.

RubyGems system software updated
[root@localhost src]# gem install rubygems-update
Successfully installed rubygems-update-2.1.0
Parsing documentation for rubygems-update-2.1.0
1 gem installed
[root@localhost src]# update_rubygems
RubyGems 2.1.0 installed
Installing ri documentation for rubygems-2.1.0
/usr/lib/ruby/1.8/rdoc/rdoc.rb:280: warning: conflicting chdir during another chdir block
/usr/lib/ruby/1.8/rdoc/rdoc.rb:287: warning: conflicting chdir during another chdir block



------------------------------------------------------------------------------

RubyGems installed the following executables:
     /usr/bin/gem

Ruby Interactive (ri) documentation was installed. ri is kind of like man
pages for ruby libraries. You may access it like this:
  ri Classname
  ri Classname.class_method
  ri Classname#instance_method
If you do not wish to install this documentation in the future, use the
--no-document flag, or set it as the default in your ~/.gemrc file. See
'gem help env' for details.

[root@localhost src]# ruby -v
ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux]
[root@localhost src]# gem -v
2.1.0
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# gem install rails
Fetching: i18n-0.6.5.gem (100%)
Successfully installed i18n-0.6.5
Fetching: multi_json-1.8.0.gem (100%)
Successfully installed multi_json-1.8.0
Fetching: tzinfo-0.3.37.gem (100%)
Successfully installed tzinfo-0.3.37
Fetching: atomic-1.1.13-java.gem (100%)
Successfully installed atomic-1.1.13-java
Fetching: thread_safe-0.1.2-java.gem (100%)
Successfully installed thread_safe-0.1.2-java
Fetching: activesupport-4.0.0.gem (100%)
Successfully installed activesupport-4.0.0
Fetching: builder-3.1.4.gem (100%)
Successfully installed builder-3.1.4
Fetching: rack-1.5.2.gem (100%)
Successfully installed rack-1.5.2
Fetching: rack-test-0.6.2.gem (100%)
Successfully installed rack-test-0.6.2
Fetching: erubis-2.7.0.gem (100%)
Successfully installed erubis-2.7.0
Fetching: actionpack-4.0.0.gem (100%)
Successfully installed actionpack-4.0.0
Fetching: activemodel-4.0.0.gem (100%)
Successfully installed activemodel-4.0.0
Fetching: arel-4.0.0.gem (100%)
Successfully installed arel-4.0.0
Fetching: activerecord-deprecated_finders-1.0.3.gem (100%)
Successfully installed activerecord-deprecated_finders-1.0.3
Fetching: activerecord-4.0.0.gem (100%)
Successfully installed activerecord-4.0.0
Fetching: mime-types-1.25.gem (100%)
Successfully installed mime-types-1.25
Fetching: polyglot-0.3.3.gem (100%)
Successfully installed polyglot-0.3.3
Fetching: treetop-1.4.15.gem (100%)
Successfully installed treetop-1.4.15
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    SSL_connect SYSCALL returned=5 errno=0 state=SSLv3 read server session ticket A (https://rubygems.org/gems/mail-2.5.4.gem)
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# gem install rake
Fetching: rake-10.1.0.gem (100%)
rake's executable "rake" conflicts with /usr/local/src/rbenv/versions/2.0.0-p247/bin/rake
Overwrite the executable? [yN]  y
Successfully installed rake-10.1.0
Parsing documentation for rake-10.1.0
Installing ri documentation for rake-10.1.0
1 gem installed
[root@localhost src]# ruby install rails
ruby: No such file or directory -- install (LoadError)
[root@localhost src]# gem install rails
Fetching: mail-2.5.4.gem (100%)
Successfully installed mail-2.5.4
Fetching: actionmailer-4.0.0.gem (100%)
Successfully installed actionmailer-4.0.0
Fetching: thor-0.18.1.gem (100%)
Successfully installed thor-0.18.1
Fetching: railties-4.0.0.gem (100%)
Successfully installed railties-4.0.0
Fetching: hike-1.2.3.gem (100%)
Successfully installed hike-1.2.3
Fetching: tilt-1.4.1.gem (100%)
Successfully installed tilt-1.4.1
Fetching: sprockets-2.10.0.gem (100%)
Successfully installed sprockets-2.10.0
Fetching: sprockets-rails-2.0.0.gem (100%)
Successfully installed sprockets-rails-2.0.0
Fetching: rails-4.0.0.gem (100%)
Successfully installed rails-4.0.0
Parsing documentation for actionmailer-4.0.0
Installing ri documentation for actionmailer-4.0.0
Parsing documentation for hike-1.2.3
Installing ri documentation for hike-1.2.3
Parsing documentation for mail-2.5.4
unable to convert "\x80" from ASCII-8BIT to UTF-8 for lib/mail/values/unicode_tables.dat, skipping
Installing ri documentation for mail-2.5.4
Parsing documentation for rails-4.0.0
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/belongs_to.png, skipping
unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/book_icon.gif, skipping
unable to convert "\x91" from ASCII-8BIT to UTF-8 for guides/assets/images/bullet.gif, skipping
unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/chapters_icon.gif, skipping
unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/check_bullet.gif, skipping
unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/credits_pic_blank.gif, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/csrf.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/edge_badge.png, skipping
unable to convert "\x9E" from ASCII-8BIT to UTF-8 for guides/assets/images/favicon.ico, skipping
unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/feature_tile.gif, skipping
unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/footer_tile.gif, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/fxn.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/challenge.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/confirm_dialog.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/forbidden_attributes_for_new_post.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/form_with_errors.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/index_action_with_edit_link.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/new_post.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/post_with_comments.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/rails_welcome.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_controller.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_route_matches.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/show_action_for_posts.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/template_is_missing_posts_new.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/undefined_method_post_path.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_create_for_posts.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_new_for_posts.png, skipping
unable to convert "\xF0" from ASCII-8BIT to UTF-8 for guides/assets/images/grey_bullet.gif, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/habtm.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many_through.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one_through.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/header_backdrop.png, skipping
unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/header_tile.gif, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_html_safe.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_localized_pirate.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_en.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_pirate.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translation_missing.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_untranslated.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/1.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/10.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/11.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/12.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/13.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/14.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/15.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/2.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/3.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/4.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/5.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/6.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/7.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/8.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/9.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/caution.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/example.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/home.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/important.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/next.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/note.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/prev.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/tip.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/up.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/warning.png, skipping
unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/jaimeiniesta.jpg, skipping
unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/nav_arrow.gif, skipping
unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/oscardelben.jpg, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/polymorphic.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/radar.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/rails4_features.png, skipping
unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_kindle_cover.jpg, skipping
unable to convert "\xEC" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_logo.gif, skipping
unable to convert "\x8C" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_logo_remix.gif, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/session_fixation.png, skipping
unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_grey.gif, skipping
unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_info.gif, skipping
unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_note.gif, skipping
unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_red.gif, skipping
unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.gif, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.png, skipping
unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/vijaydev.jpg, skipping
Installing ri documentation for rails-4.0.0
Parsing documentation for railties-4.0.0
Installing ri documentation for railties-4.0.0
Parsing documentation for sprockets-2.10.0
Installing ri documentation for sprockets-2.10.0
Parsing documentation for sprockets-rails-2.0.0
Installing ri documentation for sprockets-rails-2.0.0
Parsing documentation for thor-0.18.1
Installing ri documentation for thor-0.18.1
Parsing documentation for tilt-1.4.1
Installing ri documentation for tilt-1.4.1
9 gems installed
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# yum -y install ruby-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * extras: mirrors.btte.net
 * updates: centos.ustc.edu.cn
base                                                                                              | 3.7 kB     00:00
extras                                                                                            | 3.4 kB     00:00
updates                                                                                           | 3.4 kB     00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ruby-devel.x86_64 0:1.8.7.352-12.el6_4 will be installed
--> Processing Dependency: ruby-libs = 1.8.7.352-12.el6_4 for package: ruby-devel-1.8.7.352-12.el6_4.x86_64
--> Running transaction check
---> Package ruby-libs.x86_64 0:1.8.7.352-10.el6_4 will be updated
--> Processing Dependency: ruby-libs = 1.8.7.352-10.el6_4 for package: ruby-1.8.7.352-10.el6_4.x86_64
---> Package ruby-libs.x86_64 0:1.8.7.352-12.el6_4 will be an update
--> Running transaction check
---> Package ruby.x86_64 0:1.8.7.352-10.el6_4 will be updated
--> Processing Dependency: ruby = 1.8.7.352-10.el6_4 for package: ruby-irb-1.8.7.352-10.el6_4.x86_64
---> Package ruby.x86_64 0:1.8.7.352-12.el6_4 will be an update
--> Running transaction check
---> Package ruby-irb.x86_64 0:1.8.7.352-10.el6_4 will be updated
--> Processing Dependency: ruby-irb = 1.8.7.352-10.el6_4 for package: ruby-rdoc-1.8.7.352-10.el6_4.x86_64
---> Package ruby-irb.x86_64 0:1.8.7.352-12.el6_4 will be an update
--> Running transaction check
---> Package ruby-rdoc.x86_64 0:1.8.7.352-10.el6_4 will be updated
---> Package ruby-rdoc.x86_64 0:1.8.7.352-12.el6_4 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================
 Package                     Arch                    Version                              Repository                Size
=========================================================================================================================
Installing:
 ruby-devel                  x86_64                  1.8.7.352-12.el6_4                   updates                  314 k
Updating for dependencies:
 ruby                        x86_64                  1.8.7.352-12.el6_4                   updates                  534 k
 ruby-irb                    x86_64                  1.8.7.352-12.el6_4                   updates                  313 k
 ruby-libs                   x86_64                  1.8.7.352-12.el6_4                   updates                  1.6 M
 ruby-rdoc                   x86_64                  1.8.7.352-12.el6_4                   updates                  376 k

Transaction Summary
=========================================================================================================================
Install       1 Package(s)
Upgrade       4 Package(s)

Total download size: 3.1 M
Downloading Packages:
(1/5): ruby-1.8.7.352-12.el6_4.x86_64.rpm                                                         | 534 kB     00:07
(2/5): ruby-devel-1.8.7.352-12.el6_4.x86_64.rpm                                                   | 314 kB     00:02
(3/5): ruby-irb-1.8.7.352-12.el6_4.x86_64.rpm                                                     | 313 kB     00:05
(4/5): ruby-libs-1.8.7.352-12.el6_4.x86_64.rpm                                                    | 1.6 MB     00:32
(5/5): ruby-rdoc-1.8.7.352-12.el6_4.x86_64.rpm                                                    | 376 kB     00:03
-------------------------------------------------------------------------------------------------------------------------
Total                                                                                     51 kB/s | 3.1 MB     01:03
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : ruby-libs-1.8.7.352-12.el6_4.x86_64                                                                   1/9
  Updating   : ruby-1.8.7.352-12.el6_4.x86_64                                                                        2/9
  Updating   : ruby-irb-1.8.7.352-12.el6_4.x86_64                                                                    3/9
  Updating   : ruby-rdoc-1.8.7.352-12.el6_4.x86_64                                                                   4/9
  Installing : ruby-devel-1.8.7.352-12.el6_4.x86_64                                                                  5/9
  Cleanup    : ruby-rdoc-1.8.7.352-10.el6_4.x86_64                                                                   6/9
  Cleanup    : ruby-irb-1.8.7.352-10.el6_4.x86_64                                                                    7/9
  Cleanup    : ruby-1.8.7.352-10.el6_4.x86_64                                                                        8/9
  Cleanup    : ruby-libs-1.8.7.352-10.el6_4.x86_64                                                                   9/9
  Verifying  : ruby-1.8.7.352-12.el6_4.x86_64                                                                        1/9
  Verifying  : ruby-irb-1.8.7.352-12.el6_4.x86_64                                                                    2/9
  Verifying  : ruby-devel-1.8.7.352-12.el6_4.x86_64                                                                  3/9
  Verifying  : ruby-libs-1.8.7.352-12.el6_4.x86_64                                                                   4/9
  Verifying  : ruby-rdoc-1.8.7.352-12.el6_4.x86_64                                                                   5/9
  Verifying  : ruby-libs-1.8.7.352-10.el6_4.x86_64                                                                   6/9
  Verifying  : ruby-rdoc-1.8.7.352-10.el6_4.x86_64                                                                   7/9
  Verifying  : ruby-1.8.7.352-10.el6_4.x86_64                                                                        8/9
  Verifying  : ruby-irb-1.8.7.352-10.el6_4.x86_64                                                                    9/9

Installed:
  ruby-devel.x86_64 0:1.8.7.352-12.el6_4

Dependency Updated:
  ruby.x86_64 0:1.8.7.352-12.el6_4        ruby-irb.x86_64 0:1.8.7.352-12.el6_4   ruby-libs.x86_64 0:1.8.7.352-12.el6_4
  ruby-rdoc.x86_64 0:1.8.7.352-12.el6_4

Complete!
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# ls
rbenv
[root@localhost src]# ruby -v
ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux]
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# rails --version
-bash: rails: command not found
[root@localhost src]# rails
-bash: rails: command not found
[root@localhost src]# rails s
-bash: rails: command not found
[root@localhost src]# gem install rack
Successfully installed rack-1.5.2
Parsing documentation for rack-1.5.2
Installing ri documentation for rack-1.5.2
1 gem installed
[root@localhost src]# yum -y install gcc
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * extras: mirrors.btte.net
 * updates: centos.ustc.edu.cn
Setting up Install Process
Package gcc-4.4.7-3.el6.x86_64 already installed and latest version
Nothing to do
[root@localhost src]# yum -y install make
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * extras: mirrors.btte.net
 * updates: centos.ustc.edu.cn
Setting up Install Process
Package 1:make-3.81-20.el6.x86_64 already installed and latest version
Nothing to do
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# gem update rails
Updating installed gems
Nothing to update
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# gem i rails --version 4.0.0 --no-ri --no-doc
Successfully installed rails-4.0.0
1 gem installed
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# rails
-bash: rails: command not found
[root@localhost src]# rails -v
-bash: rails: command not found
[root@localhost src]# sudo rails -v
sudo: rails: command not found
[root@localhost src]# ruby -v
ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux]
[root@localhost src]# gem -v
2.1.0
[root@localhost src]# rvm -v
-bash: rvm: command not found
[root@localhost src]# rvm list known
-bash: rvm: command not found
[root@localhost src]# curl -L https://get.rvm.io | bash -s stable
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 15779  100 15779    0     0   1428      0  0:00:11  0:00:11 --:--:-- 70128
Downloading RVM from wayneeseguin branch stable
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 1078k  100 1078k    0     0  76604      0  0:00:14  0:00:14 --:--:--  350k
Creating group 'rvm'

Installing RVM to /usr/local/rvm/
Installation of RVM in /usr/local/rvm/ is almost complete:

  * First you need to add all users that will be using rvm to 'rvm' group,
    and logout - login again, anyone using rvm will be operating with `umask u=rwx,g=rwx,o=rx`.

  * To start using RVM you need to run `source /etc/profile.d/rvm.sh`
    in all your open shell windows, in rare cases you need to reopen all shell windows.

# Administrator,
#
#   Thank you for using RVM!
#   I sincerely hope that RVM helps to make your life easier and more enjoyable!!!
#
# ~Wayne

# In case of problems:
#      run and read: rvm notes
#         read docs: http://rvm.io/
#        talk to us: http://webchat.freenode.net/?channels=rvm (http://freenode.net/faq.shtml#plusr)
#   read cheatsheet: http://cheat.errtheblog.com/s/rvm
#  watch screencast: http://screencasts.org/episodes/how-to-use-rvm
# open a bug report: https://github.com/wayneeseguin/rvm/issues
[root@localhost src]# ls
rbenv
[root@localhost src]# rvm -v
-bash: rvm: command not found
[root@localhost src]# source ~/.bashrc
[root@localhost src]# source ~/.bashrc
[root@localhost src]# source ~/.bash_profile
[root@localhost src]# ls
rbenv
[root@localhost src]# rvm -v
-bash: rvm: command not found
[root@localhost src]# ruby -v
ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux]
[root@localhost src]# ls
rbenv
[root@localhost src]# rails --version
/usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError)
     from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies'
     from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each'
     from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies'
     from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate'
     from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies'
     from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each'
     from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies'
     from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate'
     from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem'
     from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# ls rbenv [root@localhost src]# gem install rails Successfully installed rails-4.0.0 Parsing documentation for rails-4.0.0 unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/belongs_to.png, skipping unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/book_icon.gif, skipping unable to convert "\x91" from ASCII-8BIT to UTF-8 for guides/assets/images/bullet.gif, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/chapters_icon.gif, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/check_bullet.gif, skipping unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/credits_pic_blank.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/csrf.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/edge_badge.png, skipping unable to convert "\x9E" from ASCII-8BIT to UTF-8 for guides/assets/images/favicon.ico, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/feature_tile.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/footer_tile.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/fxn.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/challenge.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/confirm_dialog.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/forbidden_attributes_for_new_post.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/form_with_errors.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/index_action_with_edit_link.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/new_post.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/post_with_comments.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/rails_welcome.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_controller.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_route_matches.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/show_action_for_posts.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/template_is_missing_posts_new.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/undefined_method_post_path.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_create_for_posts.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_new_for_posts.png, skipping unable to convert "\xF0" from ASCII-8BIT to UTF-8 for guides/assets/images/grey_bullet.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/habtm.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many_through.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one_through.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/header_backdrop.png, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/header_tile.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_html_safe.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_localized_pirate.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_en.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_pirate.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translation_missing.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_untranslated.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/1.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/10.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/11.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/12.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/13.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/14.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/15.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/2.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/3.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/4.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/5.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/6.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/7.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/8.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/9.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/caution.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/example.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/home.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/important.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/next.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/note.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/prev.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/tip.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/up.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/warning.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/jaimeiniesta.jpg, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/nav_arrow.gif, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/oscardelben.jpg, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/polymorphic.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/radar.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/rails4_features.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_kindle_cover.jpg, skipping unable to convert "\xEC" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_logo.gif, skipping unable to convert "\x8C" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_logo_remix.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/session_fixation.png, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_grey.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_info.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_note.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_red.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/vijaydev.jpg, skipping 1 gem installed [root@localhost src]# rails -v /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# [root@localhost src]# [root@localhost src]# gem list *** LOCAL GEMS *** actionmailer (4.0.0) actionpack (4.0.0) activemodel (4.0.0) activerecord (4.0.0) activerecord-deprecated_finders (1.0.3) activesupport (4.0.0) arel (4.0.0) atomic (1.1.13 java) bigdecimal (1.2.0) builder (3.1.4) bundler (1.3.5) erubis (2.7.0) hike (1.2.3) i18n (0.6.5) io-console (0.4.2) json (1.7.7) mail (2.5.4) mime-types (1.25) minitest (4.3.2) multi_json (1.8.0) polyglot (0.3.3) psych (2.0.0) rack (1.5.2) rack-test (0.6.2) rails (4.0.0) railties (4.0.0) rake (10.1.0, 0.9.6) rdoc (4.0.0) rubygems-update (2.1.0) sprockets (2.10.0) sprockets-rails (2.0.0) test-unit (2.0.0.0) thor (0.18.1) thread_safe (0.1.2 java) tilt (1.4.1) treetop (1.4.15) tzinfo (0.3.37) [root@localhost src]# gem install --version 0.1.2 thread_safe [root@localhost src]# rails -v /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# gem install --version 0.1.2 thread_safe [root@localhost src]# rails -v /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# gem install rails Successfully installed rails-4.0.0 Parsing documentation for rails-4.0.0 unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/belongs_to.png, skipping unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/book_icon.gif, skipping unable to convert "\x91" from ASCII-8BIT to UTF-8 for guides/assets/images/bullet.gif, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/chapters_icon.gif, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/check_bullet.gif, skipping unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/credits_pic_blank.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/csrf.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/edge_badge.png, skipping unable to convert "\x9E" from ASCII-8BIT to UTF-8 for guides/assets/images/favicon.ico, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/feature_tile.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/footer_tile.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/fxn.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/challenge.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/confirm_dialog.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/forbidden_attributes_for_new_post.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/form_with_errors.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/index_action_with_edit_link.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/new_post.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/post_with_comments.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/rails_welcome.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_controller.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_route_matches.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/show_action_for_posts.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/template_is_missing_posts_new.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/undefined_method_post_path.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_create_for_posts.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_new_for_posts.png, skipping unable to convert "\xF0" from ASCII-8BIT to UTF-8 for guides/assets/images/grey_bullet.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/habtm.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many_through.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one_through.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/header_backdrop.png, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/header_tile.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_html_safe.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_localized_pirate.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_en.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_pirate.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translation_missing.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_untranslated.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/1.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/10.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/11.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/12.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/13.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/14.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/15.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/2.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/3.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/4.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/5.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/6.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/7.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/8.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/9.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/caution.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/example.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/home.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/important.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/next.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/note.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/prev.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/tip.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/up.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/warning.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/jaimeiniesta.jpg, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/nav_arrow.gif, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/oscardelben.jpg, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/polymorphic.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/radar.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/rails4_features.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_kindle_cover.jpg, skipping unable to convert "\xEC" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_logo.gif, skipping unable to convert "\x8C" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_logo_remix.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/session_fixation.png, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_grey.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_info.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_note.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_red.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/vijaydev.jpg, skipping 1 gem installed [root@localhost src]# rails -v /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# vi ~/.bashrc [root@localhost src]# source ~/.bashrc [root@localhost src]# gem install rails Successfully installed rails-4.0.0 Parsing documentation for rails-4.0.0 unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/belongs_to.png, skipping unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/book_icon.gif, skipping unable to convert "\x91" from ASCII-8BIT to UTF-8 for guides/assets/images/bullet.gif, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/chapters_icon.gif, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/check_bullet.gif, skipping unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/credits_pic_blank.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/csrf.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/edge_badge.png, skipping unable to convert "\x9E" from ASCII-8BIT to UTF-8 for guides/assets/images/favicon.ico, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/feature_tile.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/footer_tile.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/fxn.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/challenge.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/confirm_dialog.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/forbidden_attributes_for_new_post.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/form_with_errors.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/index_action_with_edit_link.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/new_post.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/post_with_comments.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/rails_welcome.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_controller.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_route_matches.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/show_action_for_posts.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/template_is_missing_posts_new.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/undefined_method_post_path.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_create_for_posts.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_new_for_posts.png, skipping unable to convert "\xF0" from ASCII-8BIT to UTF-8 for guides/assets/images/grey_bullet.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/habtm.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many_through.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one_through.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/header_backdrop.png, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/header_tile.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_html_safe.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_localized_pirate.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_en.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_pirate.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translation_missing.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_untranslated.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/1.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/10.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/11.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/12.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/13.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/14.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/15.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/2.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/3.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/4.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/5.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/6.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/7.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/8.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/9.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/caution.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/example.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/home.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/important.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/next.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/note.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/prev.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/tip.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/up.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/warning.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/jaimeiniesta.jpg, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/nav_arrow.gif, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/oscardelben.jpg, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/polymorphic.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/radar.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/rails4_features.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_kindle_cover.jpg, skipping unable to convert "\xEC" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_logo.gif, skipping unable to convert "\x8C" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_logo_remix.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/session_fixation.png, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_grey.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_info.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_note.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_red.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/vijaydev.jpg, skipping 1 gem installed [root@localhost src]# rails -v /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# gem install thread_safe [root@localhost src]# thread_safe -v -bash: thread_safe: command not found [root@localhost src]# rails -v /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# gem install rails Successfully installed rails-4.0.0 Parsing documentation for rails-4.0.0 unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/belongs_to.png, skipping unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/book_icon.gif, skipping unable to convert "\x91" from ASCII-8BIT to UTF-8 for guides/assets/images/bullet.gif, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/chapters_icon.gif, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/check_bullet.gif, skipping unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/credits_pic_blank.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/csrf.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/edge_badge.png, skipping unable to convert "\x9E" from ASCII-8BIT to UTF-8 for guides/assets/images/favicon.ico, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/feature_tile.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/footer_tile.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/fxn.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/challenge.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/confirm_dialog.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/forbidden_attributes_for_new_post.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/form_with_errors.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/index_action_with_edit_link.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/new_post.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/post_with_comments.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/rails_welcome.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_controller.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_route_matches.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/show_action_for_posts.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/template_is_missing_posts_new.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/undefined_method_post_path.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_create_for_posts.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_new_for_posts.png, skipping unable to convert "\xF0" from ASCII-8BIT to UTF-8 for guides/assets/images/grey_bullet.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/habtm.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many_through.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one_through.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/header_backdrop.png, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/header_tile.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_html_safe.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_localized_pirate.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_en.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_pirate.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translation_missing.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_untranslated.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/1.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/10.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/11.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/12.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/13.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/14.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/15.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/2.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/3.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/4.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/5.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/6.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/7.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/8.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/9.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/caution.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/example.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/home.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/important.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/next.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/note.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/prev.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/tip.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/up.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/warning.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/jaimeiniesta.jpg, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/nav_arrow.gif, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/oscardelben.jpg, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/polymorphic.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/radar.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/rails4_features.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_kindle_cover.jpg, skipping unable to convert "\xEC" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_logo.gif, skipping unable to convert "\x8C" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_logo_remix.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/session_fixation.png, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_grey.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_info.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_note.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_red.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/vijaydev.jpg, skipping 1 gem installed [root@localhost src]# rails uninstall /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# rails -v /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# rails tes /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# gem uninstall rails Successfully uninstalled rails-4.0.0 [root@localhost src]# rails -v /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# gem uninstall rails [root@localhost src]# rails -v /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' [root@localhost src]# gem install rails ^CERROR: Interrupted [root@localhost src]# ^C [root@localhost src]# rvm -v -bash: rvm: command not found [root@localhost src]# gem rvm install ERROR: While executing gem ... (Gem::CommandLineError) Unknown command rvm [root@localhost src]# gem -v 2.1.0 [root@localhost src]# which gem /usr/local/src/rbenv/shims/gem [root@localhost src]# rvm --default use 2.0.0-p247 -bash: rvm: command not found [root@localhost src]# ruby -v ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux] [root@localhost src]# rvm install -bash: rvm: command not found [root@localhost src]# gem update --system Latest version currently installed. Aborting. [root@localhost src]# gem install rubygems-update Successfully installed rubygems-update-2.1.0 Parsing documentation for rubygems-update-2.1.0 1 gem installed [root@localhost src]# bundler -v -bash: bundler: command not found [root@localhost src]# gem list *** LOCAL GEMS *** actionmailer (4.0.0) actionpack (4.0.0) activemodel (4.0.0) activerecord (4.0.0) activerecord-deprecated_finders (1.0.3) activesupport (4.0.0) arel (4.0.0) atomic (1.1.13 java) bigdecimal (1.2.0) builder (3.1.4) bundler (1.3.5) erubis (2.7.0) hike (1.2.3) i18n (0.6.5) io-console (0.4.2) json (1.7.7) mail (2.5.4) mime-types (1.25) minitest (4.3.2) multi_json (1.8.0) polyglot (0.3.3) psych (2.0.0) rack (1.5.2) rack-test (0.6.2) railties (4.0.0) rake (10.1.0, 0.9.6) rdoc (4.0.0) rubygems-update (2.1.0) sprockets (2.10.0) sprockets-rails (2.0.0) test-unit (2.0.0.0) thor (0.18.1) thread_safe (0.1.2 java) tilt (1.4.1) treetop (1.4.15) tzinfo (0.3.37) [root@localhost src]# ruby -v ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux] [root@localhost src]# rbenv list rbenv: no such command `list' [root@localhost src]# rbenv list rbenv: no such command `list' [root@localhost src]# rbenv --list rbenv: no such command `--list' [root@localhost src]# rbenv -list rbenv: no such command `-list' [root@localhost src]# which gem /usr/local/src/rbenv/shims/gem [root@localhost src]# rails -v /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'thread_safe' (~> 0.1) - did find: [thread_safe-0.1.2-java] (Gem::LoadError) from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1265:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1268:in `block in activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `each' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1254:in `activate_dependencies' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1236:in `activate' from /usr/local/src/rbenv/versions/2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem' from /usr/local/src/rbenv/versions/2.0.0-p247/bin/rails:22:in `
' ■2日目の挫折ログ harapekoAir:rails_study harapeko$ cd ugoke/ harapekoAir:ugoke harapeko$ virtualbox -v 2013-09-10 22:43:58.377 VirtualBox[26840:f07] -_continuousScroll is deprecated for NSScrollWheel. Please use -hasPreciseScrollingDeltas. 2013-09-10 22:43:58.377 VirtualBox[26840:f07] -deviceDeltaX is deprecated for NSScrollWheel. Please use -scrollingDeltaX. 2013-09-10 22:43:58.378 VirtualBox[26840:f07] -deviceDeltaY is deprecated for NSScrollWheel. Please use -scrollingDeltaY. harapekoAir:ugoke harapeko$ virtualbox -v harapekoAir:ugoke harapeko$ virtualbox -v harapekoAir:ugoke harapeko$ virtualbox -v harapekoAir:ugoke harapeko$ ls harapekoAir:ugoke harapeko$ pwd /Users/harapeko/study/rails_study/ugoke harapekoAir:ugoke harapeko$ ls harapekoAir:ugoke harapeko$ ls harapekoAir:ugoke harapeko$ ls harapekoAir:ugoke harapeko$ pwd /Users/harapeko/study/rails_study/ugoke harapekoAir:ugoke harapeko$ ls harapekoAir:ugoke harapeko$ vagrant init centos64 A `Vagrantfile` has been placed in this directory. You are now ready to `vagrant up` your first virtual environment! Please read the comments in the Vagrantfile as well as documentation on `vagrantup.com` for more information on using Vagrant. harapekoAir:ugoke harapeko$ vagrant up Bringing machine 'default' up with 'virtualbox' provider... [default] Importing base box 'centos64'... [default] Matching MAC address for NAT networking... [default] Setting the name of the VM... [default] Clearing any previously set forwarded ports... [default] Creating shared folders metadata... [default] Clearing any previously set network interfaces... [default] Preparing network interfaces based on configuration... [default] Forwarding ports... [default] -- 22 => 2222 (adapter 1) [default] Booting VM... [default] Waiting for machine to boot. This may take a few minutes... [default] Machine booted and ready! [default] Mounting shared folders... [default] -- /vagrant harapekoAir:ugoke harapeko$ vagrant ssh Welcome to your Vagrant-built virtual machine. [vagrant@localhost ~]$ su - パスワード: [root@localhost ~]# logout [vagrant@localhost ~]$ su パスワード: [root@localhost vagrant]# ls [root@localhost vagrant]# pwd /home/vagrant [root@localhost vagrant]# cd /usr/local/ [root@localhost local]# ls bin etc games include lib lib64 libexec sbin share src [root@localhost local]# cd src/ [root@localhost src]# ls [root@localhost src]# cd ../ [root@localhost local]# git clone git://github.com/sstephenson/rbenv.git rbenv bash: git: コマンドが見つかりません [root@localhost local]# vagrant -v bash: vagrant: コマンドが見つかりません [root@localhost local]# yum -y install gcc openssl-devel make git Loaded plugins: fastestmirror Determining fastest mirrors * base: ftp.riken.jp * extras: mirrors.stuhome.net * updates: mirrors.stuhome.net base | 3.7 kB 00:00 base/primary_db | 4.4 MB 00:02 extras | 3.4 kB 00:00 extras/primary_db | 18 kB 00:00 updates | 3.4 kB 00:00 updates/primary_db | 4.4 MB 00:03 Setting up Install Process Package gcc-4.4.7-3.el6.x86_64 already installed and latest version Package openssl-devel-1.0.0-27.el6_4.2.x86_64 already installed and latest version Package 1:make-3.81-20.el6.x86_64 already installed and latest version Resolving Dependencies --> Running transaction check ---> Package git.x86_64 0:1.7.1-3.el6_4.1 will be installed --> Processing Dependency: perl-Git = 1.7.1-3.el6_4.1 for package: git-1.7.1-3.el6_4.1.x86_64 --> Processing Dependency: rsync for package: git-1.7.1-3.el6_4.1.x86_64 --> Processing Dependency: perl(Git) for package: git-1.7.1-3.el6_4.1.x86_64 --> Processing Dependency: perl(Error) for package: git-1.7.1-3.el6_4.1.x86_64 --> Running transaction check ---> Package perl-Error.noarch 1:0.17015-4.el6 will be installed ---> Package perl-Git.noarch 0:1.7.1-3.el6_4.1 will be installed ---> Package rsync.x86_64 0:3.0.6-9.el6 will be installed --> Finished Dependency Resolution Dependencies Resolved ========================================================================================================================= Package Arch Version Repository Size ========================================================================================================================= Installing: git x86_64 1.7.1-3.el6_4.1 updates 4.6 M Installing for dependencies: perl-Error noarch 1:0.17015-4.el6 base 29 k perl-Git noarch 1.7.1-3.el6_4.1 updates 28 k rsync x86_64 3.0.6-9.el6 base 334 k Transaction Summary ========================================================================================================================= Install 4 Package(s) Total download size: 5.0 M Installed size: 15 M Downloading Packages: (1/4): git-1.7.1-3.el6_4.1.x86_64.rpm | 4.6 MB 00:03 (2/4): perl-Error-0.17015-4.el6.noarch.rpm | 29 kB 00:00 (3/4): perl-Git-1.7.1-3.el6_4.1.noarch.rpm | 28 kB 00:00 (4/4): rsync-3.0.6-9.el6.x86_64.rpm | 334 kB 00:01 ------------------------------------------------------------------------------------------------------------------------- Total 775 kB/s | 5.0 MB 00:06 Running rpm_check_debug Running Transaction Test Transaction Test Succeeded Running Transaction Installing : 1:perl-Error-0.17015-4.el6.noarch 1/4 Installing : rsync-3.0.6-9.el6.x86_64 2/4 Installing : perl-Git-1.7.1-3.el6_4.1.noarch 3/4 Installing : git-1.7.1-3.el6_4.1.x86_64 4/4 Verifying : git-1.7.1-3.el6_4.1.x86_64 1/4 Verifying : rsync-3.0.6-9.el6.x86_64 2/4 Verifying : perl-Git-1.7.1-3.el6_4.1.noarch 3/4 Verifying : 1:perl-Error-0.17015-4.el6.noarch 4/4 Installed: git.x86_64 0:1.7.1-3.el6_4.1 Dependency Installed: perl-Error.noarch 1:0.17015-4.el6 perl-Git.noarch 0:1.7.1-3.el6_4.1 rsync.x86_64 0:3.0.6-9.el6 Complete! [root@localhost local]# git clone git://github.com/sstephenson/rbenv.git rbenv Initialized empty Git repository in /usr/local/rbenv/.git/ remote: Counting objects: 1651, done. remote: Compressing objects: 100% (672/672), done. Receiving objects: 100% (1651/1651), 239.64 KiB | 255 KiB/s, done. remote: Total 1651 (delta 1063), reused 1478 (delta 947) Resolving deltas: 100% (1063/1063), done. [root@localhost local]# ls bin etc games include lib lib64 libexec rbenv sbin share src [root@localhost local]# cd rbenv [root@localhost rbenv]# ls LICENSE README.md bin completions libexec test [root@localhost rbenv]# cd ../ [root@localhost local]# mkdir rbenv/shims rbenv/versions [root@localhost local]# groupadd rbenv [root@localhost local]# chgrp -R rbenv rbenv [root@localhost local]# chmod -R g+rwxXs rbenv [root@localhost local]# git clone git://github.com/sstephenson/ruby-build.git ruby-build Initialized empty Git repository in /usr/local/ruby-build/.git/ remote: Counting objects: 2153, done. remote: Compressing objects: 100% (1255/1255), done. remote: Total 2153 (delta 954), reused 1880 (delta 711) Receiving objects: 100% (2153/2153), 287.75 KiB | 324 KiB/s, done. Resolving deltas: 100% (954/954), done. [root@localhost local]# cd ruby-build [root@localhost ruby-build]# ./install.sh Installed ruby-build at /usr/local [root@localhost ruby-build]# vi /etc/profile profile profile.d/ [root@localhost ruby-build]# vi /etc/profile.d/rbenv.sh [root@localhost ruby-build]# rbenv install -l bash: rbenv: コマンドが見つかりません [root@localhost ruby-build]# cd ../../ [root@localhost usr]# pwd /usr [root@localhost usr]# cd local/ [root@localhost local]# rbenv -v bash: rbenv: コマンドが見つかりません [root@localhost local]# gem -v 1.3.7 [root@localhost local]# gem install bundler Successfully installed bundler-1.3.5 1 gem installed Installing ri documentation for bundler-1.3.5... Installing RDoc documentation for bundler-1.3.5... [root@localhost local]# exit exit [vagrant@localhost ~]$ exit logout Connection to 127.0.0.1 closed. harapekoAir:ugoke harapeko$ vagrant halt [default] Attempting graceful shutdown of VM... harapekoAir:ugoke harapeko$ vagrant up Bringing machine 'default' up with 'virtualbox' provider... [default] Clearing any previously set forwarded ports... [default] Creating shared folders metadata... [default] Clearing any previously set network interfaces... [default] Preparing network interfaces based on configuration... [default] Forwarding ports... [default] -- 22 => 2222 (adapter 1) [default] Booting VM... [default] Waiting for machine to boot. This may take a few minutes... [default] Machine booted and ready! [default] Mounting shared folders... [default] -- /vagrant harapekoAir:ugoke harapeko$ vagrant -v Vagrant 1.3.1 harapekoAir:ugoke harapeko$ vagrant ssh Last login: Tue Sep 10 14:12:09 2013 from 10.0.2.2 Welcome to your Vagrant-built virtual machine. [vagrant@localhost ~]$ su パスワード: [root@localhost vagrant]# rbenv install -l Available versions: 1.8.6-p383 1.8.6-p420 1.8.7-p249 1.8.7-p302 1.8.7-p334 1.8.7-p352 1.8.7-p357 1.8.7-p358 1.8.7-p370 1.8.7-p371 1.8.7-p374 1.9.1-p378 1.9.1-p430 1.9.2-p0 1.9.2-p180 1.9.2-p290 1.9.2-p318 1.9.2-p320 1.9.3-dev 1.9.3-p0 1.9.3-p125 1.9.3-p194 1.9.3-p286 1.9.3-p327 1.9.3-p362 1.9.3-p374 1.9.3-p385 1.9.3-p392 1.9.3-p429 1.9.3-p448 1.9.3-preview1 1.9.3-rc1 2.0.0-dev 2.0.0-p0 2.0.0-p195 2.0.0-p247 2.0.0-preview1 2.0.0-preview2 2.0.0-rc1 2.0.0-rc2 2.1.0-dev jruby-1.5.6 jruby-1.6.3 jruby-1.6.4 jruby-1.6.5 jruby-1.6.5.1 jruby-1.6.6 jruby-1.6.7 jruby-1.6.7.2 jruby-1.6.8 jruby-1.7.0 jruby-1.7.0-preview1 jruby-1.7.0-preview2 jruby-1.7.0-rc1 jruby-1.7.0-rc2 jruby-1.7.1 jruby-1.7.2 jruby-1.7.3 jruby-1.7.4 maglev-1.0.0 maglev-1.1.0-dev maglev-2.0.0-dev mruby-dev rbx-1.2.4 rbx-2.0.0-dev rbx-2.0.0-rc1 ree-1.8.6-2009.06 ree-1.8.7-2009.09 ree-1.8.7-2009.10 ree-1.8.7-2010.01 ree-1.8.7-2010.02 ree-1.8.7-2011.03 ree-1.8.7-2011.12 ree-1.8.7-2012.01 ree-1.8.7-2012.02 topaz-dev [root@localhost vagrant]# rbenv install 2.0.0-p247 Downloading ruby-2.0.0-p247.tar.gz... -> http://cache.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p247.tar.gz Installing ruby-2.0.0-p247... Installed ruby-2.0.0-p247 to /usr/local/rbenv/versions/2.0.0-p247 [root@localhost vagrant]# ruby -v ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux] [root@localhost vagrant]# rbenv global 2.0.0-p247 [root@localhost vagrant]# ruby -v ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux] [root@localhost vagrant]# vi /etc/resolv.conf [root@localhost vagrant]# vi ~/.gemrc [root@localhost vagrant]# ls [root@localhost vagrant]# cd /usr/local/ [root@localhost local]# ls bin etc games include lib lib64 libexec rbenv ruby-build sbin share src [root@localhost local]# rbenv rehash [root@localhost local]# ruby -v ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux] [root@localhost local]# gem list bundler *** LOCAL GEMS *** [root@localhost local]# gem install bundler ERROR: Could not find a valid gem '–no-ri' (>= 0) in any repository ERROR: Possible alternatives: nori ERROR: Could not find a valid gem '–no-rdoc' (>= 0) in any repository ^CERROR: Interrupted [root@localhost local]# ^C [root@localhost local]# rm ~/.gemrc rm: remove 通常ファイル `/root/.gemrc'? [root@localhost local]# ls bin etc games include lib lib64 libexec rbenv ruby-build sbin share src [root@localhost local]# cd ~/ [root@localhost ~]# ls anaconda-ks.cfg install.log install.log.syslog [root@localhost ~]# cd /root [root@localhost ~]# ls anaconda-ks.cfg install.log install.log.syslog [root@localhost ~]# gem list bundler *** LOCAL GEMS *** [root@localhost ~]# gem install bundler ERROR: Could not find a valid gem '–no-ri' (>= 0) in any repository ERROR: Possible alternatives: nori ERROR: Could not find a valid gem '–no-rdoc' (>= 0) in any repository ^CERROR: Interrupted [root@localhost ~]# ^C [root@localhost ~]# vi ~/.gemrc [root@localhost ~]# gem install bundler Failed to load /root/.gemrc because it doesn't contain valid YAML hash Fetching: bundler-1.3.5.gem (100%) Successfully installed bundler-1.3.5 Parsing documentation for bundler-1.3.5 Installing ri documentation for bundler-1.3.5 1 gem installed [root@localhost ~]# gem list bundler Failed to load /root/.gemrc because it doesn't contain valid YAML hash *** LOCAL GEMS *** bundler (1.3.5) [root@localhost ~]# gem update bundler Failed to load /root/.gemrc because it doesn't contain valid YAML hash Updating installed gems Nothing to update [root@localhost ~]# gem install rails –no-ri –no-rdoc Failed to load /root/.gemrc because it doesn't contain valid YAML hash ^CERROR: Interrupted [root@localhost ~]# ^C [root@localhost ~]# cd /root/ [root@localhost ~]# ls anaconda-ks.cfg install.log install.log.syslog [root@localhost ~]# cd .gemrc bash: cd: .gemrc: ディレクトリではありません [root@localhost ~]# rm ~/.gemrc rm: remove 通常ファイル `/root/.gemrc'? yes [root@localhost ~]# rm /root/.gemrc rm: cannot remove `/root/.gemrc': そのようなファイルやディレクトリはありません [root@localhost ~]# rm ~/.gemrc rm: cannot remove `/root/.gemrc': そのようなファイルやディレクトリはありません [root@localhost ~]# gem install rails –no-ri –no-rdoc Fetching: i18n-0.6.5.gem (100%) Successfully installed i18n-0.6.5 Fetching: multi_json-1.8.0.gem (100%) Successfully installed multi_json-1.8.0 Fetching: tzinfo-0.3.37.gem (100%) Successfully installed tzinfo-0.3.37 Fetching: atomic-1.1.13.gem (100%) Building native extensions. This could take a while... Successfully installed atomic-1.1.13 Fetching: thread_safe-0.1.3.gem (100%) Successfully installed thread_safe-0.1.3 Fetching: activesupport-4.0.0.gem (100%) Successfully installed activesupport-4.0.0 Fetching: builder-3.1.4.gem (100%) Successfully installed builder-3.1.4 Fetching: rack-1.5.2.gem (100%) Successfully installed rack-1.5.2 Fetching: rack-test-0.6.2.gem (100%) Successfully installed rack-test-0.6.2 Fetching: erubis-2.7.0.gem (100%) Successfully installed erubis-2.7.0 Fetching: actionpack-4.0.0.gem (100%) Successfully installed actionpack-4.0.0 Fetching: activemodel-4.0.0.gem (100%) Successfully installed activemodel-4.0.0 Fetching: arel-4.0.0.gem (100%) Successfully installed arel-4.0.0 Fetching: activerecord-deprecated_finders-1.0.3.gem (100%) Successfully installed activerecord-deprecated_finders-1.0.3 Fetching: activerecord-4.0.0.gem (100%) Successfully installed activerecord-4.0.0 Fetching: mime-types-1.25.gem (100%) Successfully installed mime-types-1.25 Fetching: polyglot-0.3.3.gem (100%) Successfully installed polyglot-0.3.3 Fetching: treetop-1.4.15.gem (100%) Successfully installed treetop-1.4.15 Fetching: mail-2.5.4.gem (100%) Successfully installed mail-2.5.4 Fetching: actionmailer-4.0.0.gem (100%) Successfully installed actionmailer-4.0.0 Fetching: thor-0.18.1.gem (100%) Successfully installed thor-0.18.1 Fetching: railties-4.0.0.gem (100%) Successfully installed railties-4.0.0 Fetching: hike-1.2.3.gem (100%) Successfully installed hike-1.2.3 Fetching: tilt-1.4.1.gem (100%) Successfully installed tilt-1.4.1 Fetching: sprockets-2.10.0.gem (100%) Successfully installed sprockets-2.10.0 Fetching: sprockets-rails-2.0.0.gem (100%) Successfully installed sprockets-rails-2.0.0 Fetching: rails-4.0.0.gem (100%) Successfully installed rails-4.0.0 Parsing documentation for i18n-0.6.5 Installing ri documentation for i18n-0.6.5 Parsing documentation for multi_json-1.8.0 Installing ri documentation for multi_json-1.8.0 Parsing documentation for tzinfo-0.3.37 Installing ri documentation for tzinfo-0.3.37 Parsing documentation for atomic-1.1.13 unable to convert "\xA0" from ASCII-8BIT to UTF-8 for lib/atomic_reference.so, skipping Installing ri documentation for atomic-1.1.13 Parsing documentation for thread_safe-0.1.3 Installing ri documentation for thread_safe-0.1.3 Parsing documentation for activesupport-4.0.0 unable to convert "\x80" from ASCII-8BIT to UTF-8 for lib/active_support/values/unicode_tables.dat, skipping Installing ri documentation for activesupport-4.0.0 Parsing documentation for builder-3.1.4 /usr/local/rbenv/versions/2.0.0-p247/lib/ruby/2.0.0/rdoc/parser.rb:87: warning: Unsupported encoding : ignored /usr/local/rbenv/versions/2.0.0-p247/lib/ruby/2.0.0/rdoc/parser.rb:87: warning: Unsupported encoding ignored Installing ri documentation for builder-3.1.4 Parsing documentation for rack-1.5.2 Installing ri documentation for rack-1.5.2 Parsing documentation for rack-test-0.6.2 Installing ri documentation for rack-test-0.6.2 Parsing documentation for erubis-2.7.0 Installing ri documentation for erubis-2.7.0 Parsing documentation for actionpack-4.0.0 Installing ri documentation for actionpack-4.0.0 Parsing documentation for activemodel-4.0.0 Installing ri documentation for activemodel-4.0.0 Parsing documentation for arel-4.0.0 Installing ri documentation for arel-4.0.0 Parsing documentation for activerecord-deprecated_finders-1.0.3 Installing ri documentation for activerecord-deprecated_finders-1.0.3 Parsing documentation for activerecord-4.0.0 Installing ri documentation for activerecord-4.0.0 Parsing documentation for mime-types-1.25 Installing ri documentation for mime-types-1.25 Parsing documentation for polyglot-0.3.3 Installing ri documentation for polyglot-0.3.3 Parsing documentation for treetop-1.4.15 Installing ri documentation for treetop-1.4.15 Parsing documentation for mail-2.5.4 unable to convert "\x80" from ASCII-8BIT to UTF-8 for lib/mail/values/unicode_tables.dat, skipping Installing ri documentation for mail-2.5.4 Parsing documentation for actionmailer-4.0.0 Installing ri documentation for actionmailer-4.0.0 Parsing documentation for thor-0.18.1 Installing ri documentation for thor-0.18.1 Parsing documentation for railties-4.0.0 Installing ri documentation for railties-4.0.0 Parsing documentation for hike-1.2.3 Installing ri documentation for hike-1.2.3 Parsing documentation for tilt-1.4.1 Installing ri documentation for tilt-1.4.1 Parsing documentation for sprockets-2.10.0 Installing ri documentation for sprockets-2.10.0 Parsing documentation for sprockets-rails-2.0.0 Installing ri documentation for sprockets-rails-2.0.0 Parsing documentation for rails-4.0.0 unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/belongs_to.png, skipping unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/book_icon.gif, skipping unable to convert "\x91" from ASCII-8BIT to UTF-8 for guides/assets/images/bullet.gif, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/chapters_icon.gif, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/check_bullet.gif, skipping unable to convert "\xF4" from ASCII-8BIT to UTF-8 for guides/assets/images/credits_pic_blank.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/csrf.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/edge_badge.png, skipping unable to convert "\x9E" from ASCII-8BIT to UTF-8 for guides/assets/images/favicon.ico, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/feature_tile.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/footer_tile.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/fxn.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/challenge.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/confirm_dialog.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/forbidden_attributes_for_new_post.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/form_with_errors.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/index_action_with_edit_link.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/new_post.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/post_with_comments.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/rails_welcome.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_controller.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/routing_error_no_route_matches.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/show_action_for_posts.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/template_is_missing_posts_new.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/undefined_method_post_path.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_create_for_posts.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/getting_started/unknown_action_new_for_posts.png, skipping unable to convert "\xF0" from ASCII-8BIT to UTF-8 for guides/assets/images/grey_bullet.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/habtm.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_many_through.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/has_one_through.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/header_backdrop.png, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/header_tile.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_html_safe.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_localized_pirate.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_en.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translated_pirate.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_translation_missing.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/i18n/demo_untranslated.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/1.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/10.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/11.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/12.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/13.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/14.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/15.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/2.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/3.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/4.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/5.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/6.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/7.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/8.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/callouts/9.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/caution.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/example.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/home.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/important.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/next.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/note.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/prev.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/tip.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/up.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/icons/warning.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/jaimeiniesta.jpg, skipping unable to convert "\xF5" from ASCII-8BIT to UTF-8 for guides/assets/images/nav_arrow.gif, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/oscardelben.jpg, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/polymorphic.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/radar.png, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/rails4_features.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_kindle_cover.jpg, skipping unable to convert "\xEC" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_guides_logo.gif, skipping unable to convert "\x8C" from ASCII-8BIT to UTF-8 for guides/assets/images/rails_logo_remix.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/session_fixation.png, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_grey.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_info.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_note.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_red.gif, skipping unable to convert "\x80" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.gif, skipping unable to convert "\x89" from ASCII-8BIT to UTF-8 for guides/assets/images/tab_yellow.png, skipping unable to convert "\xFF" from ASCII-8BIT to UTF-8 for guides/assets/images/vijaydev.jpg, skipping Installing ri documentation for rails-4.0.0 ERROR: Could not find a valid gem '–no-ri' (>= 0) in any repository ERROR: Possible alternatives: nori ERROR: Could not find a valid gem '–no-rdoc' (>= 0) in any repository ERROR: Possible alternatives: ooor-doc 27 gems installed [root@localhost ~]# rails -v bash: rails: コマンドが見つかりません [root@localhost ~]# gem install rails --no-rdoc --no-ri Successfully installed rails-4.0.0 1 gem installed [root@localhost ~]# rails -v bash: rails: コマンドが見つかりません [root@localhost ~]# rails -v bash: rails: コマンドが見つかりません [root@localhost ~]# gem list *** LOCAL GEMS *** actionmailer (4.0.0) actionpack (4.0.0) activemodel (4.0.0) activerecord (4.0.0) activerecord-deprecated_finders (1.0.3) activesupport (4.0.0) arel (4.0.0) atomic (1.1.13) bigdecimal (1.2.0) builder (3.1.4) bundler (1.3.5) erubis (2.7.0) hike (1.2.3) i18n (0.6.5) io-console (0.4.2) json (1.7.7) mail (2.5.4) mime-types (1.25) minitest (4.3.2) multi_json (1.8.0) polyglot (0.3.3) psych (2.0.0) rack (1.5.2) rack-test (0.6.2) rails (4.0.0) railties (4.0.0) rake (0.9.6) rdoc (4.0.0) sprockets (2.10.0) sprockets-rails (2.0.0) test-unit (2.0.0.0) thor (0.18.1) thread_safe (0.1.3) tilt (1.4.1) treetop (1.4.15) tzinfo (0.3.37) [root@localhost ~]# rails --version bash: rails: コマンドが見つかりません [root@localhost ~]# rails --versions bash: rails: コマンドが見つかりません [root@localhost ~]# rails -versions bash: rails: コマンドが見つかりません [root@localhost ~]# rails --version bash: rails: コマンドが見つかりません [root@localhost ~]# rails -v bash: rails: コマンドが見つかりません [root@localhost ~]# apt-get install build-essential bash: apt-get: コマンドが見つかりません [root@localhost ~]# rails s bash: rails: コマンドが見つかりません [root@localhost ~]# exit exit [vagrant@localhost ~]$ exit logout Connection to 127.0.0.1 closed. harapekoAir:ugoke harapeko$ vagrant halt [default] Attempting graceful shutdown of VM... harapekoAir:ugoke harapeko$ vagrant up Bringing machine 'default' up with 'virtualbox' provider... v[default] Clearing any previously set forwarded ports... agr[default] Creating shared folders metadata... a[default] Clearing any previously set network interfaces... [default] Preparing network interfaces based on configuration... n[default] Forwarding ports... t[default] -- 22 => 2222 (adapter 1) [default] Booting VM... ssh[default] Waiting for machine to boot. This may take a few minutes... su vagrant [default] Machine booted and ready! [default] Mounting shared folders... [default] -- /vagrant harapekoAir:ugoke harapeko$ vagrant ssh Last login: Tue Sep 10 15:23:31 2013 from 10.0.2.2 su vagrant Welcome to your Vagrant-built virtual machine. [vagrant@localhost ~]$ su パスワード: [root@localhost vagrant]# rbenv rehash [root@localhost vagrant]# rails -v Rails 4.0.0 [root@localhost vagrant]#

■railsを勉強するにあたって参考になりそうな書籍(現在読んでいるものとか)